CVE-2020-26222 – Dependabot is a set of packages for automated dependency management for Ruby, JavaScript, …

Vuln ID: CVE-2020-26222

Published:  2020-11-13  16:15:18Z

Description: Dependabot is a set of packages for automated dependency management for Ruby, JavaScript, Python, PHP, Elixir, Rust, Java, .NET, Elm and Go.
In Dependabot-Core from version 0.119.0.beta1 before version 0.125.1, there is a remote code execution vulnerability in dependabot-common and dependabot-go_modules when a source branch name contains malicious injectable bash code.

For example, if Dependabot is configured to use the following source branch name: "/$({curl,127.0.0.1})", Dependabot will make a HTTP request to the following URL: 127.0.0.1 when cloning the source repository.

The fix was applied to version 0.125.1.

As a workaround, one can escape the branch name prior to passing it to the Dependabot::Source class.

Source: NVD.NIST.GOV