CVE-2020-11995 – A deserialization vulnerability existed in dubbo 2.7.5 and its earlier versions, which cou …

Vuln ID: CVE-2020-11995

Published:  2021-01-11  10:15:13Z

Description: A deserialization vulnerability existed in dubbo 2.7.5 and its earlier versions, which could lead to malicious code execution. Most Dubbo users use Hessian2 as the default serialization/deserialization protool, during Hessian2 deserializing the HashMap object, some functions in the classes stored in HasMap will be executed after a series of program calls, however, those special functions may cause remote command execution. For example, the hashCode() function of the EqualsBean class in rome-1.7.0.jar will cause the remotely load malicious classes and execute malicious code by constructing a malicious request. This issue was fixed in Apache Dubbo 2.6.9 and 2.7.8.

Source: NVD.NIST.GOV