CVE-2020-25205 – The web console for Mimosa B5, B5c, and C5x firmware through 2.8.0.2 is vulnerable to stor …

Vuln ID: CVE-2020-25205

Published:  2021-07-20  19:15:09Z

Description: The web console for Mimosa B5, B5c, and C5x firmware through 2.8.0.2 is vulnerable to stored XSS in the set_banner() function of /var/www/core/controller/index.php. An unauthenticated attacker may set the contents of the /mnt/jffs2/banner.txt file, stored on the device’s filesystem, to contain arbitrary JavaScript. The file contents are then used as part of a welcome/banner message presented to unauthenticated users who visit the login page for the web console. This vulnerability does not occur in the older 1.5.x firmware versions.

Source: NVD.NIST.GOV