CVE-2022-24912 – The package github.com/runatlantis/atlantis/server/controllers/events before 0.19.7 are vu …

Vuln ID: CVE-2022-24912

Published:  2022-07-29  10:15:12Z

Description: The package github.com/runatlantis/atlantis/server/controllers/events before 0.19.7 are vulnerable to Timing Attack in the webhook event validator code, which does not use a constant-time comparison function to validate the webhook secret. It can allow an attacker to recover this secret as an attacker and then forge webhook events.

Source: NVD.NIST.GOV