CVE-2022-31179 – Shescape is a simple shell escape package for JavaScript. Versions prior to 1.5.8 were fou …

Vuln ID: CVE-2022-31179

Published:  2022-08-01  20:15:08Z

Description: Shescape is a simple shell escape package for JavaScript. Versions prior to 1.5.8 were found to be subject to code injection on windows. This impacts users that use Shescape (any API function) to escape arguments for cmd.exe on Windows An attacker can omit all arguments following their input by including a line feed character (`’n’`) in the payload. This bug has been patched in [v1.5.8] which you can upgrade to now. No further changes are required. Alternatively, line feed characters (`’n’`) can be stripped out manually or the user input can be made the last argument (this only limits the impact).

Source: NVD.NIST.GOV