CVE-2021-23385 – This affects all versions of package Flask-Security. When using the get_post_logout_redire …

Vuln ID: CVE-2021-23385

Published:  2022-08-02  14:15:10Z

Description: This affects all versions of package Flask-Security. When using the get_post_logout_redirect and get_post_login_redirect functions, it is possible to bypass URL validation and redirect a user to an arbitrary URL by providing multiple back slashes such as \evil.com/path. This vulnerability is only exploitable if an alternative WSGI server other than Werkzeug is used, or the default behaviour of Werkzeug is modified using ‘autocorrect_location_header=False. **Note:** Flask-Security is not maintained anymore.

Source: NVD.NIST.GOV