CVE-2022-35923 – v8n is a javascript validation library. Versions of v8n prior to 1.5.1 were found to have …

Vuln ID: CVE-2022-35923

Published:  2022-08-02  20:15:09Z

Description: v8n is a javascript validation library. Versions of v8n prior to 1.5.1 were found to have an inefficient regular expression complexity in the `lowercase()` and `uppercase()` regex which could lead to a denial of service attack. In testing of the `lowercase()` function a payload of ‘a’ + ‘a’.repeat(i) + ‘A’ with 32 leading characters took 29443 ms to execute. The same issue happens with uppercase(). Users are advised to upgrade. There are no known workarounds for this issue.

Source: NVD.NIST.GOV