CVE-2022-35927 – Contiki-NG is an open-source, cross-platform operating system for IoT devices. In the RPL- …

Vuln ID: CVE-2022-35927

Published:  2022-08-04  21:15:08Z

Description: Contiki-NG is an open-source, cross-platform operating system for IoT devices. In the RPL-Classic routing protocol implementation in the Contiki-NG operating system, an incoming DODAG Information Option (DIO) control message can contain a prefix information option with a length parameter. The value of the length parameter is not validated, however, and it is possible to cause a buffer overflow when copying the prefix in the set_ip_from_prefix function. This vulnerability affects anyone running a Contiki-NG version prior to 4.7 that can receive RPL DIO messages from external parties. To obtain a patched version, users should upgrade to Contiki-NG 4.7 or later. There are no workarounds for this issue.

Source: NVD.NIST.GOV