CVE-2022-2417 – Insufficient validation in GitLab CE/EE affecting all versions from 12.10 prior to 15.0.5, …

Vuln ID: CVE-2022-2417

Published:  2022-08-05  16:15:11Z

Description: Insufficient validation in GitLab CE/EE affecting all versions from 12.10 prior to 15.0.5, 15.1 prior to 15.1.4, and 15.2 prior to 15.2.1 allows an authenticated and authorised user to import a project that includes branch names which are 40 hexadecimal characters, which could be abused in supply chain attacks where a victim pinned to a specific Git commit of the project.

Source: NVD.NIST.GOV