CVE-2022-39217 – some-natalie/ghas-to-csv (GitHub Advanced Security to CSV) is a GitHub action which scrape …

Vuln ID: CVE-2022-39217

Published:  2022-09-17  00:15:10Z

Description: some-natalie/ghas-to-csv (GitHub Advanced Security to CSV) is a GitHub action which scrapes the GitHub Advanced Security API and shoves it into a CSV. In affected versions this GitHub Action creates a CSV file without sanitizing the output of the APIs. If an alert is dismissed or any other custom field contains executable code / formulas, it might be run when an endpoint opens that CSV file in a spreadsheet program. This issue has been addressed in version `v1`. Users are advised to use `v1` or later. There are no known workarounds for this issue.

Source: NVD.NIST.GOV