CVE-2022-34917 – A security vulnerability has been identified in Apache Kafka. It affects all releases sinc …

Vuln ID: CVE-2022-34917

Published:  2022-09-20  09:15:09Z

Description: A security vulnerability has been identified in Apache Kafka. It affects all releases since 2.8.0. The vulnerability allows malicious unauthenticated clients to allocate large amounts of memory on brokers. This can lead to brokers hitting OutOfMemoryException and causing denial of service. Example scenarios: – Kafka cluster without authentication: Any clients able to establish a network connection to a broker can trigger the issue. – Kafka cluster with SASL authentication: Any clients able to establish a network connection to a broker, without the need for valid SASL credentials, can trigger the issue. – Kafka cluster with TLS authentication: Only clients able to successfully authenticate via TLS can trigger the issue. We advise the users to upgrade the Kafka installations to one of the 3.2.3, 3.1.2, 3.0.2, 2.8.2 versions.

Source: NVD.NIST.GOV