CVE-2022-28802 – Code by Zapier before 2022-08-17 allowed intra-account privilege escalation that included …

Vuln ID: CVE-2022-28802

Published:  2022-09-21  20:15:10Z

Description: Code by Zapier before 2022-08-17 allowed intra-account privilege escalation that included execution of Python or JavaScript code. In other words, Code by Zapier was providing a customer-controlled general-purpose virtual machine that unintentionally granted full access to all users of a company’s account, but was supposed to enforce role-based access control within that company’s account. Before 2022-08-17, a customer could have resolved this by (in effect) using a separate virtual machine for an application that held credentials – or other secrets – that weren’t supposed to be shared among all of its employees. (Multiple accounts would have been needed to operate these independent virtual machines.)

Source: NVD.NIST.GOV