CVE-2022-26112 – In 0.10.0 or older versions of Apache Pinot, Pinot query endpoint and realtime ingestion l …

Vuln ID: CVE-2022-26112

Published:  2022-09-23  08:15:08Z

Description: In 0.10.0 or older versions of Apache Pinot, Pinot query endpoint and realtime ingestion layer has a vulnerability in unprotected environments due to a groovy function support. In order to avoid this, we disabled the groovy function support by default from Pinot release 0.11.0. See https://docs.pinot.apache.org/basics/releases/0.11.0

Source: NVD.NIST.GOV