CVE-2022-2566 – A heap out-of-bounds memory write exists in FFMPEG since version 5.1. The size calculation …

Vuln ID: CVE-2022-2566

Published:  2022-09-23  12:15:10Z

Description: A heap out-of-bounds memory write exists in FFMPEG since version 5.1. The size calculation in `build_open_gop_key_points()` goes through all entries in the loop and adds `sc->ctts_data[i].count` to `sc->sample_offsets_count`. This can lead to an integer overflow resulting in a small allocation with `av_calloc(). An attacker can cause remote code execution via a malicious mp4 file. We recommend upgrading past commit c953baa084607dd1d84c3bfcce3cf6a87c3e6e05

Source: NVD.NIST.GOV