CVE-2023-22485 – cmark-gfm is GitHub’s fork of cmark, a CommonMark parsing and rendering library and progra …

Vuln ID: CVE-2023-22485

Published:  2023-01-24  01:15:10Z

Description: cmark-gfm is GitHub’s fork of cmark, a CommonMark parsing and rendering library and program in C. In versions prior 0.29.0.gfm.7, a crafted markdown document can trigger an out-of-bounds read in the `validate_protocol` function. We believe this bug is harmless in practice, because the out-of-bounds read accesses `malloc` metadata without causing any visible damage.This vulnerability has been patched in 0.29.0.gfm.7.

Source: NVD.NIST.GOV